Launch Course
Flash player 8 or above is required.
If you are unable to view the content, raise a helpdesk request to install PEACY package - Multimedia Player (269).
Best viewed in 1024 X 768 screen resolution.